封面

麦田Mxml报表语法1.0

（标签：html，head，style，pagesetting，body， span，line，img，p，div，ul，table）

连云港麦田软件开发有限公司 2014编制


Html标签

表示报表语法的开始与结束。

Copyright ©2010 - 2014 MTCNSOFT.com.All rights reserved.
Powered By: MTCN Group


Head报表头部标签

用于定义报表的不可见属性比如样式、打印机设置等信息。


Style样式标签

用于定义报表的样式信息，只能嵌入在head标签里。


Pagesetting打印机标签

用于定义打印机信息，只能嵌入在head标签里。

属性：

名称 | 说明
landscape | 标签用于设置打印机纸张是横向还是纵向走纸。True 表示横向，False表示纵向。
paperkind | 标签用于设置打印机纸张类型，取值范围见（附录1）当取值为Custom时，控件将按paperwidth，paperheight标签设置的纸张名称创建自定义纸张。
papername | 定义报表的名称。
paperwidth | 标签用于设置自定义纸张的宽度，最小及默认单位为mm。
paperheight | 标签用于设置自定义纸张的高度，最小及默认单位为mm。
pageleft | 表示左边距，最小及默认单位为mm。
pageright | 表示右边距，最小及默认单位为mm。
pagetop | 表示顶部边距，最小及默认单位为mm。
pagebottom | 表示底部边距，最小及默认单位为mm。
fontname | 定义默认字体。
fontsize | 定义默认字体大小。
doctype | 表示选择打印机类型，1为票据打印（如：针式打印机），2为卡证打印，3为普通打印。
resolutionkind | 表示打印的清晰度，值越小分辨率越高，同时也很耗材。取值范围：1，2，3。
copies | 设置打印份数，缺省为1。


Body报表主体标签

表示报表的正文内容。一份报表可以多次定义Body标签，表示报表有多页。


Span文本标签

属性： x，y，style。

名称 | 说明
x | 定义文本内容在打印纸张中，距左边的距离。单位：cm|mm 缺省：mm。
y | 定义文本内容在打印纸张中，距顶部的距离。单位：cm|mm 缺省：mm。
class | 指定样式名称。可以指定多个。如： class= "style1 style2"
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。

Style样式支持的属性：

名称 | 说明
width | 文本范围的宽度。单位：cm|mm 缺省：mm。
height | 文本范围的高度。单位：cm|mm 缺省：mm。
font-family | 字体名称。如：font-family:宋体。
font-size | 字体大小。如：font-size:10
font-style | 字体样式。取值范围为：regular| bold|italic|strikeout| underline，分别表示：一般、粗体、斜体、带删除线、带下划线。
background-color | 背景色。
color | 文本颜色。
text-align | 文本水平对齐方式。（当设置width,height值时生效）。取值范围为：left|right|center。
text-valign | 文本垂直对齐方式。（当设置width,height值时生效）。取值范围为：top|middle|bottom。
text-trimming | 指定如何在不完全适合布局形状的字符串中修整字符。取值范围为：character| ellipsis| ellipsispath| ellipsisword| none| word。等同于C#中的System.Drawing.StringTrimming枚举。注意：设置此属性值时，需要同时配合text-formatflags的设置才能生效。
text-formatflags | 指定文本字符串的显示和布局信息。取值范围为：righttoleft| vertical| displaycontrol| fitblackbox| linelimit| trailingspace| noclip| nofontfallback| nowrap。等同于C#中的System.Drawing. StringFormatFlags枚举。
border | 定义边框粗细。单位：cm|mm 缺省：mm。
border-color | 定义边框的线条颜色。
border-style | 定义边框的样式。取值范围为：d dash|dashdot|dashdotdot|dot|solid。
padding | 填充文本边框与文本内容之间的空白。


Line线条标签

属性

名称 | 说明
x | 线条起点的X坐标。单位：cm|mm 缺省：mm。
y | 线条起点的Y坐标。单位：cm|mm 缺省：mm。
endx | 线条末点的X坐标。单位：cm|mm 缺省：mm。
endy | 线条末点的Y坐标。单位：cm|mm 缺省：mm。
class | 指定样式名称。可以指定多个。如： class= "style1 style2"
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。

Style样式支持的属性

名称 | 说明
border | 定义边框粗细。单位：cm|mm 缺省：mm。
border-color | 定义边框的线条颜色。
border-style | 定义边框的样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
padding | 填充文本边框与文本内容之间的空白。


Img 图片标签

属性

名称 | 说明
x | 定义文本内容在打印纸张中，距左边的距离。单位：cm|mm 缺省：mm。
y | 定义文本内容在打印纸张中，距顶部的距离。单位：cm|mm 缺省：mm。
src | 图片地址。基于站点虚拟路径。如：/images/logo.jpg
byte | 采用编码文本显示图片。当值为：true时。可以将标签间的Base64文本，解析为图片。
alt | 当无法显示图片时，显示的替代文本。
class | 指定样式名称。可以指定多个。如： class= "style1 style2"
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。

Style样式支持的属性

名称 | 说明
width | 图片宽度。单位：cm|mm 缺省：mm。
height | 图片高度。单位：cm|mm 缺省：mm。
font-family | 替代文本字体名称。如：font-family:宋体。
font-size | 替代文本字体大小。如：font-size:10
font-style | 替代文本字体样式。取值范围为：regular|bold|italic|strikeout| underline，分别表示：一般、粗体、斜体、带删除线、带下划线。
color | 替代文本颜色。
text-align | 替代文本水平对齐方式。（当设置width,height值时生效）。取值范围为：left|right|center。
text-valign | 替代文本垂直对齐方式。（当设置width,height值时生效）。取值范围为：top|middle|bottom。
padding | 填充文本边框与文本内容之间的空白。


P 段落标签（高级文本）

<p>…</p>段落标签内支持<span>文本，<strong>粗体，<em>斜体，<br />换行四个子标签。

属性： x，y，style。

名称 | 说明
x | 定义文本内容在打印纸张中，距左边的距离。单位：cm|mm 缺省：mm。
y | 定义文本内容在打印纸张中，距顶部的距离。单位：cm|mm 缺省：mm。
class | 指定样式名称。可以指定多个。如： class= "style1 style2"
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。

Style样式支持的属性：

名称 | 说明
width | 文本范围的宽度。单位：cm|mm 缺省：mm。
height | 文本范围的高度。单位：cm|mm 缺省：mm。当高度值未定义或为0时，段落将根据内容自适应高度。
font-family | 字体名称。如：font-family:宋体。
font-size | 字体大小。如：font-size:10
font-style | 字体样式。取值范围为regular|bold|italic|strikeout| underline，分别表示：一般、粗体、斜体、带删除线、带下划线。
background-color | 背景色。
color | 文本颜色。
text-align | 文本水平对齐方式。（当设置width,height值时生效）。取值范围为：left|right|center。
text-valign | 文本垂直对齐方式。（当设置width,height值时生效）。取值范围为：top|middle|bottom。
text-autospace | 控制段落中的行内容是否向两端对齐，取值范围:true|false。
text-decoration | 控制文本是否显示下划线，取值范围: underline。
border | 定义边框粗细。单位：cm|mm 缺省：mm。
border-color | 定义边框的线条颜色。
border-style | 定义边框的样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
padding | 填充文本边框与文本内容之间的空白。
letter-spacing | 每个字的水平间隔。
line-height | 段落的行距。


Div 容器标签

属性： x，y，format，style。

名称 | 说明
x | 定义文本内容在打印纸张中，距左边的距离。单位：cm|mm 缺省：mm。
y | 定义文本内容在打印纸张中，距顶部的距离。单位：cm|mm 缺省：mm。
format | 取值范围：p| child，默认是child。P表示DIV的用法等于P，child表示DIV里必需内嵌子标签。
class | 指定样式名称。可以指定多个。如： class= "style1 style2"
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。

Style样式支持的属性：

名称 | 说明
width | 文本范围的宽度。单位：cm|mm 缺省：mm。
height | 文本范围的高度。单位：cm|mm 缺省：mm。
background-color | 背景色。
border | 定义边框粗细。单位：cm|mm 缺省：mm。
border-color | 定义边框的线条颜色。
border-style | 边框的样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
padding | 填充文本边框与文本内容之间的空白。
border | 边框粗细。单位：cm|mm 缺省：mm。
border-width | 边框粗细。
border-style | 边框样式。
border-color | 边框颜色。
border-top-width | 顶部边框粗细。
border-right-width | 右边边框粗细。
border-bottom-width | 底部边框粗细。
border-left-width | 左边边框粗细。
border-top-style | 顶部边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-right-style | 右边边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-bottom-style | 底部边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-left-style | 左边边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-top-color | 顶部边框颜色。
border-right-color | 右边边框颜色。
border-bottom-color | 底部边框颜色。
border-left-color | 左边边框颜色。


Ul 容器集合标签

<ul>

<li>…</li>

<li>…</li>

</ul>

Ul属性： x，y，rep。

名称 | 说明
x | 定义文本内容在打印纸张中，距左边的距离。单位：cm|mm 缺省：mm。
y | 定义文本内容在打印纸张中，距顶部的距离。单位：cm|mm 缺省：mm。
rep | 取值范围：h|v，默认是h。h表示横向排列子标签。V表示纵向排列子标签。

Li属性： format，style。

名称 | 说明
format | 取值范围：p| child| auto|text，默认是text。P表示Li的用法等于P，child表示Li里必需内嵌子标签，auto根据内容自动判断，text将Li内内容视为文本等于span。当为p段落模式时，Li将根据内容自适应高度。
class | 指定样式名称。可以指定多个。如： class= "style1 style2"
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。

Style样式支持的属性：

名称 | 说明
width | 文本范围的宽度。单位：cm|mm 缺省：mm。
height | 文本范围的高度。单位：cm|mm 缺省：mm。
font-family | 字体名称。如：font-family:宋体。
font-size | 字体大小。如：font-size:10
font-style | 字体样式。取值范围为：regular|bold|italic|strikeout| underline，分别表示：一般、粗体、斜体、带删除线、带下划线。
background-color | 背景色。
color | 文本颜色。
text-align | 文本水平对齐方式。（当设置width,height值时生效）。取值范围为：left|right|center。
text-valign | 文本垂直对齐方式。（当设置width,height值时生效）。取值范围为：top|middle|bottom。
padding | 填充文本边框与文本内容之间的空白。
border | 边框粗细。单位：cm|mm 缺省：mm。
border-width | 边框粗细。
border-style | 边框样式。
border-color | 边框颜色。
border-top-width | 顶部边框粗细。
border-right-width | 右边边框粗细。
border-bottom-width | 底部边框粗细。
border-left-width | 左边边框粗细。
border-top-style | 顶部边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-right-style | 右边边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-bottom-style | 底部边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-left-style | 左边边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-top-color | 顶部边框颜色。
border-right-color | 右边边框颜色。
border-bottom-color | 底部边框颜色。
border-left-color | 左边边框颜色。


Table 表格标签

<table x="0" y="3.5cm" style="border:0.25mm" minlines="24" pagelines="24">

<thead>

<tr height="0.6cm">

<td width="1cm" class="bold">序号</td>

<td width="2.5cm" class="bold">姓名</td>

</tr>

</thead>

<tbody class="bottom">

<tr height="0.6cm">

<td width="1cm">1</td>

<td width="2.5cm">张三</td>

</tr>

<filltr height="0.6cm">

<td width="1cm"></td>

<td width="2.5cm"></td>

</filltr>

</tbody>

<tfoot>

</tfoot>

</table>

minlines 表示每页显示的最小行数量，比如24行，假如内容不足24行，会自动填充空白行。pagelines，也可以使用maxlines 表示每页显示数据项最大行数，超过这个值将自动创建下一页进行显示（注册一个报表中只能有一个table属有pagelines属性）。Thead 表示表格头部，Tbody 表示数据项，Tfoot 表示表格底部。Tr表示行，td表示单元格，filltr表示内容达不到每页显示的最大行时，自动填充的空白行模板。

table属性

名称 | 说明
x | 定义文本内容在打印纸张中，距左边的距离。单位：cm|mm 缺省：mm。
y | 定义文本内容在打印纸张中，距顶部的距离。单位：cm|mm 缺省：mm。
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。
Style属性 | 见公共部分。

thead,tbody,tfoot属性

名称 | 说明
class | 指定样式名称。可以指定多个。如： class= "style1 style2"
style | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。
Style属性 | 见公共部分。

tr，filltr属性

名称 |  | 说明
x |  | 在相对位置上定义行的X坐标。单位：cm|mm 缺省：mm。
y |  | 在相对位置上定义行的Y坐标。单位：cm|mm 缺省：mm。
class |  | 指定样式名称。可以指定多个。如： class= "style1 style2"
style |  | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。
Style属性 | height | 定义行的高度。
 | font-family | 字体名称。如：font-family:宋体。
 | font-size | 字体大小。如：font-size:10
 | font-style | 字体样式。取值范围为：regular| bold|italic|strikeout| underline，分别表示：一般、粗体、斜体、带删除线、带下划线。
 | background-color | 背景色。
 | color | 文本颜色。
 | text-align | 文本水平对齐方式。（当设置width,height值时生效）。取值范围为：left|right|center。
 | text-valign | 文本垂直对齐方式。（当设置width,height值时生效）。取值范围为：top|middle|bottom。
 | 更多属性见公共部分。

td属性

名称 |  | 说明
x |  | 在相对位置上定义行的X坐标。单位：cm|mm 缺省：mm。
y |  | 在相对位置上定义行的Y坐标。单位：cm|mm 缺省：mm。
format |  | 取值范围：p| child| auto|text，默认是text。P表示td的用法等于P，child表示td里必需内嵌子标签，auto根据内容自动判断，text将td内内容视为文本等于span。
class |  | 指定样式名称。可以指定多个。如： class= "style1 style2"
style |  | 定义标签的样式，宽度、高度、色彩、字体、文本对齐方式等。
Style属性 | height | 定义单元格的高度。
 | width | 定义单元格的宽度。
 | font-family | 字体名称。如：font-family:宋体。
 | font-size | 字体大小。如：font-size:10
 | font-style | 字体样式。取值范围为：regular| bold|italic|strikeout| underline，分别表示：一般、粗体、斜体、带删除线、带下划线。
 | background-color | 背景色。
 | color | 文本颜色。
 | text-align | 文本水平对齐方式。（当设置width,height值时生效）。取值范围为：left|right|center。
 | text-valign | 文本垂直对齐方式。（当设置width,height值时生效）。取值范围为：top|middle|bottom。
 | 更多属性见公共部分。

公共的Style样式属性

名称 | 说明
border | 边框粗细。单位：cm|mm 缺省：mm。
border-width | 边框粗细。
border-style | 边框样式。
border-color | 边框颜色。
border-top-width | 顶部边框粗细。
border-right-width | 右边边框粗细。
border-bottom-width | 底部边框粗细。
border-left-width | 左边边框粗细。
border-top-style | 顶部边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-right-style | 右边边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-bottom-style | 底部边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-left-style | 左边边框样式。取值范围为：dash|dashdot|dashdotdot|dot|solid。
border-top-color | 顶部边框颜色。
border-right-color | 右边边框颜色。
border-bottom-color | 底部边框颜色。
border-left-color | 左边边框颜色。