Account 帐户表

记帐功能的辅助表，存储记帐的帐户信息。

字段 | 类型 | 说明
AccountID | Int | 帐户编号。
AccountName | VarChar | 帐户姓名。
Remark | VarChar | 备注。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。

Copyright ©2009 - 2019 MTCNSOFT.Com.All rights reserved.
Powered By MTCUN


Ann 公告表

系统公告数据表。

字段 | 类型 | 说明
AnnID | Int | 公告编号。
Subject | VarChar | 主题。
Viewer | Int | 可以阅读的人群。（0所有人，1内部员工，2学员）
Content | VarChar | 内容。
BrowseNum | Int | 浏览次数。
DateAndTime | DateTime | 发布日期。
TrueName | VarChar | 发布者姓名。
UserID | Int | 发布者工号。


Attend 学员出勤表

学员考勤表，此表从属于LessonDegree排课表，记录某一课次下面，所有学员的出勤信息。

字段 | 类型 | 说明
AttendID | Int | 考勤编号。
LessonTimeID | Int | 隶属的排课表编号。
StuClassID | Int | 学员选班编号。
AtStateID | Int | 考勤状态。（1正常，2迟到，3早退，4旷课，5请假）
Lessons | Decimal | 考勤有效课时。
Remark | VarChar | 备注。
SignOn | DateTime | 考勤签到时间。
SignOut | DateTime | 考勤签退时间。
Price | Currency | 本课次价值。(按收取学员的学费计算的产出)


BackLesson 异动参数

保存因异动产生退课时、退金额的参数，用于撤消异动时参考。

字段 | 类型 | 说明
ChangeID | Int | 异动编号。
BillItemID | Int | 明细单号。
Amount | Decimal | 数量。
UnitPrice | Currency | 单价。


Batch 仓库进货表

仓库进货表，记录进货退货信息。

字段 | 类型 | 说明
BatchID | VarChar | 进货编号。
BatchTypeID | Int | 进货类型，进货/退货。
DateAndTime | DateTime | 进货日期。
TotalAmount | Int | 总数量。
TotalPurchasePrice | Currency | 总价值。
ProviderID | Int | 供货商编号。
ProviderName | VarChar | 供货商名称。
Remark | VarChar | 备注。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。


BatchItem 进货明细表

进货明细表，从属于Batch进货表，记录某一批次内的具体货物品种，单价，数量等。

字段 | 类型 | 说明
BatchItemID | Int | 明细编号。
BatchID | VarChar | 隶属进货编号。
PurchasePrice | Currency | 采购价格（进价）。
Amount | Int | 数量。
UnitName | VarChar | 单位。
CommodityID | Int | 商品编号。
CommodityName | VarChar | 商品名称。
StoCommodityID | Int | 所属仓库关联表编号（注：这里不是仓库编号，而是关联表编号,StoCommodity关联表里记录了每种商品在不同仓库里的库存信息）。


Bill 消费表

消费单数据表，存储学员的消费信息，退费信息。

字段 | 类型 | 说明
BillID | VarChar | 消费单编号。
StudentID | Int | 所属学员编号。
StudentName | VarChar | 所属学员姓名。
BillTypeID | Int | 消费单类型。（0退费，1消费）
DateAndTime | DateTime | 消费日期。
Pay | Currency | 总金额。
Discount | Currency | 优惠金额。
Payables | Currency | 应付金额。
Payed | Currency | 实际支付的金额。
ThenPaid | Currency | 实际支付的金额。（包含找零）
GiveChange | Currency | 找零。
ItemsCount | Int | 收费项数目。
Remark | VarChar | 备注。
PrintCount | Int | 打印次数。
PostSchoolID | Int | 收费网点编号。
PostSchoolName | VarChar | 收费网点名称。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
InsertTime | DateTime | 数据写入时间。
PayMethodID | Int | 支付方式。
PayMethodName | VarChar | 支付方式名称。
PaymentID | Int | 扣费号。
ToPaymentID | Int | 充值号。
PaymentState | Int | 支付状态。
PayCount | Int | 支付次数。


BillItem 消费明细表

消费明细表，从属于Bill消费表，记录某一次收费的具体收费项，单价，数量等。

字段 | 类型 | 说明
BillItemID | Int | 消费明细编号。
BillID | VarChar | 消费单编号。
ProductType | Int | 收费项类型。（1课程，2收费项，8商品）
ProductID | Int | 收费项编号。（比如：商品编号、课程编号、收费项编号等）
ProductName | VarChar | 收费项名称。（比如：商品名称、课程名称、收费项名称等）
PackageID | Int | 子价格编号。
PackageName | VarChar | 子价格名称。
UnitPrice | Currency | 单价。
Amount | Decimal | 数量。
Discount | Currency | 优惠。
UnitID | Int | 单位编号。
UnitName | VarChar | 单位。
ServiceID | Int | 选班编号。
ConsumeAmount | Decimal | 消耗数量。
BackAmount | Decimal | 退回数量。
ServiceState | Int | 当收费项是课程的时候，表示是否已选班。（0未处理，1已处理）
QType | Int | 量化方式。（1按数量，2按时间）
ServiceStart | DateTime | 服务开始日期。
ServiceEnd | DateTime | 服务结束日期。
KeyID | Int | 服务编号。
SellID | Int | 当收费类型为退费时，记录原消费明细编号。
Remark | VarChar | 备注。
ContinueReg | Int | 课程类型。（0试听，1新增，2续报）
Profit | Currency | 利润金额。
CakeCount | Int | 蛋糕分配数量。
CakeText | VarChar | 文本显示分享蛋糕者。
CakeMoney | Currency | 蛋糕分配金额。


Cake 蛋糕表

用于分配营业利润提成。

字段 | 类型 | 说明
CakeID | Int | 蛋糕编号。
ToUserID | Int | 分配对象工号。
ToTrueName | VarChar | 分配对象姓名。
DateAndTime | DateTime | 时间。
CakeMoney | Currency | 分配金额。
Ratio | Decimal | 比例。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
BillItemID | Int | 明细单号。
SchoolID | Int | 校区编号。
SchoolName | VarChar | 校区名称。
InsertTime | DateTime | 数据写入时间。


Change 学员异动表

学员异动表，记录学员转班，延期休学，弃学，退学等信息。

字段 | 类型 | 说明
ChangeID | Int | 异动编号。
ChangeType | Int | 异动类型。（3转班，4休学，5退学，6弃学）
StuClassID | Int | 办理异动的学员选班号。
DateAndTime | DateTime | 办理日期。
IntoAccount | Currency | 因异动而需要退费的金额。（退入学员账户）
Lessons | Decimal | 因异动产生的退课时。
GetDateTime | DateTime | 休学到期日期。（精确到时间部分）
Remark | VarChar | 备注。
NewStuClassID | Int | 转班/休学转到的新班级选班号。
PaymentID | Int | 与学员账户关联的结算号。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。


Class 班级表

班级信息表，这张表在系统的地位重要，它关联了课程，教室，老师，排课，选班...

字段 | 类型 | 说明
ClassID | Int | 班级编号。
ClassName | VarChar | 班级名称。
CourseID | Int | 课程编号。
CourseName | VarChar | 课程名称。
ClassType | Int | 班级类型。（0为一对多大班，1为一对一）
TeacherID | Int | 教师工号。
TeacherName | VarChar | 教师姓名。
TimeRule | VarChar | 上课规律。
ClassroomID | Int | 教室编号。
ClassroomName | VarChar | 教室名称。
StartDate | DateTime | 开课时间。（精确到时间部分）
EndDate | DateTime | 结束时间。（精确到时间部分）
PlanCount | Int | 计划招生数。
StuCount | Int | 当前学员数。
CourseProgress | Decimal | 课程进度。
Lessons | Decimal | 总课时。
ArrangeLessons | Decimal | 排课进度。
LessonMinute | Int | 每课时多少分钟。
Remark | VarChar | 班级介绍。
DateAndTime | DateTime | 创建时间。
SchoolID | Int | 校区编号。
SchoolName | VarChar | 校区名称。
UserID | Int | 建立者工号。
TrueName | VarChar | 建立者姓名。
Custom1 | VarChar | 自定义字段。长度255字节。
Custom2 | VarChar | 自定义字段。长度255字节。
Custom3 | VarChar | 自定义字段。长度255字节。
Custom4 | VarChar | 自定义字段。长度255字节。
Custom5 | VarChar | 自定义字段。长度255字节。
LastArrangeDate | DateTime | 最后排课的时间。
AutoAbsent | Int | 自动处理旷课请假。（0不支持，1支持）
SetParameters | VarChar | 其它考勤参数集合。
AutoLT | Int | 一对一不排课考勤。（0不支持，1支持）
HeadTeacherID | Int | 班主任/助教编号。
HeadTeacherName | VarChar | 班主任/助教姓名。
ProspectStuCount | Int | 预订人数。（通过学员登录后台报名但未付款人数）
OpenDisplay | Int | 是否对外显示，微网站学员客户端等。（0否，1是）
LessonFee | Currency | 主讲老师课时提成。
TALessonFee | Currency | 助教课时提成。


Classroom 教室表

存储教室信息。

字段 | 类型 | 说明
ClassroomID | Int | 教室编号。
ClassroomName | VarChar | 教室名称。
Seating | Int | 容纳最大人数。
SchoolID | Int | 校区编号。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Commodity 商品表

存储仓库里的产品信息，可以显示产品的总库存。

字段 | 类型 | 说明
CommodityID | Int | 产品编号。
CommodityName | VarChar | 产品名称。
CommodityTypeID | Int | 产品分类编号。
CommodityTypeName | VarChar | 产品分类名称。
UnitName | VarChar | 单位名称。
PurchasePrice | Currency | 采购价格。（进价）
UnitPrice | Currency | 单价。（售价）
Specification | VarChar | 规格。
Amount | Int | 库存数量。
WarnAmount | Int | 库存报警警示数。（库存小于这个数字时系统会提醒）
StoreCount | Int | 仓库数。
AllowPoints | Int | 是否可以用积分兑换。（0不可以，1可以）
Points | Int | 需要兑换的积分数。
Remark | VarChar | 备注。
LockState | Int | 状态。（0禁用，1可用）
Barcode | VarChar | 条形码。


CommodityType 商品分类表

商品分类。

字段 | 类型 | 说明
CommodityTypeID | Int | 商品分类编号。
CommodityTypeName | VarChar | 商品分类名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Course 课程表

存储课程信息，包括课程的单位、价格等。

字段 | 类型 | 说明
CourseID | Int | 课程编号。
CourseName | VarChar | 课程名称。
CourseTypeID | Int | 课程类型编号。
CourseTypeName | VarChar | 课程类型名称。
UnitPrice | Currency | 单价。
UnitID | Int | 单位编号。
UnitName | VarChar | 单位名称。
Remark | VarChar | 备注。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。
LessonMinute | Int | 每课时分钟数。


CourseType 课程分类表

存储课程分类信息。

字段 | 类型 | 说明
CourseTypeID | Int | 课程分类编号。
CourseTypeName | VarChar | 课程分类名称。
Orders | Int | 排序。
LockState | Int | 状态。（0禁用，1可用）


CustomFields 自定义字段表

管理自定义字段。

字段 | 类型 | 说明
CustomID | Int | 自定义字段编号。
CustomName | VarChar | 自定义字段名称。
CustomWidth | Int | 自定义字段宽度。
TableName | VarChar | 所属哪张表。
CustomIndex | Int | 自定义字段排序号。
CustomState | Int | 状态。（0禁用，1启用）


DataSet 报表数据集

为报表开发提供自定义数据集。

字段 | 类型 | 说明
DataSetID | Int | 数据集编号。
DataSetName | VarChar | 数据集名称。
ParamName | VarChar | 参数名称。
ParamType | Int | 参数类型。（1单值，2数组）
Content | VarChar | 数据集内容。
Remark | VarChar | 备注。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


DBInfo 版本控制表

数据库版本控制表。

字段 | 类型 | 说明
VersionID | VarChar | 数据库版本。
DateAndTime | DateTime | 数据库版本日期。
LastBackupDate | DateTime | 数据库最后的备份时间。
LastBaseDbDate | DateTime | 数据库基础数据最后更新时间。
LastFingerDate | DateTime | 数据库指纹信息最后更新时间。
DefaultReport | VarChar | 默认打印报表。
LastClearDate | DateTime | 最后自动清理数据时间。
LastAutoAttendDate | DateTime | 最后处理旷课、请假时间。
SysInfo | VarChar | 系统其它信息。


Dictionary 字典表

字典功能，用于记忆曾经输入的数据。比如：曾经输入的学员学校、年级、工作单位、职务等，系统会自动将它写入字典，下次输入时会自动弹出供选择。

字段 | 类型 | 说明
DictionaryID | Int | 字典编号。
DictionaryName | VarChar | 字典名称。
DictionaryType | Int | 字典分类。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


EvalTeacher 评价老师表

记录学员评价老师的信息。

字段 | 类型 | 说明
EvalTeacherID | Int | 评价老师编号。
TeacherID | Int | 老师工号。
TeacherName | VarChar | 老师姓名。
Level | Int | 评价级别。
Content | VarChar | 评价内容。
DateAndTime | DateTime | 时间。
Teach | Int | 是否是你的代课老师。（0不是，1是）
StudentID | Int | 学员学号。
StudentName | VarChar | 学员姓名。


Finger 指纹变更表

为远程指纹仪考勤工具提供实时的学员指纹变化信息。

字段 | 类型 | 说明
FingerID | Int | 指纹编号。
UserType | Int | 用户类型。（1学员 2员工）
FingerCode | VarChar | 指纹代码。
Action | Int | 执行方式。（0删除,1新增,2更新）
DateAndTime | DateTime | 日期。


GrabClass 抢班表

记录学员通过客户端抢报班级的信息，抢到班级名额后如果一定时间内没有完成支付，系统将自动释放。

字段 | 类型 | 说明
GrabClassID | Int | 抢班编号。
ClassID | Int | 班级编号。
StudentID | Int | 学员学号。
DateAndTime | DateTime | 时间。


GroupUsers 用户与角色关系表

用户与角色（用户组）之间的关系表。

字段 | 类型 | 说明
UserGroupID | Int | 用户组编号。
UserID | Int | 用户编号。
SchoolID | Int | 校区编号。
Orders | Int | 排序。


Holiday 假期表

存储假期数据表，用于排课时自动跳过节假日。

字段 | 类型 | 说明
HolidayID | Int | 假期编号。
HolidayName | VarChar | 假期名称。
StartDate | DateTime | 开始时间。
EndDate | DateTime | 结束时间。
Orders | Int | 排序。


ImportLog 导入日志表

记录导入潜在/正式学员的批次，可用于数据回滚。

字段 | 类型 | 说明
ImportBatchID | Int | 导入批次号。
FileName | VarChar | 文件名。
FileSize | Int | 文件大小。
Rows | Int | 行数。
DataType | Int | 数据分类。（0潜在，1正式）
DateAndTime | DateTime | 时间。
UserID | Int | 操作者工号。
TrueName | VarChar | 操作者姓名。
State | Int | 状态。（1已导入，0已撤回）


Income 记帐表

记录机构日常收支信息。

字段 | 类型 | 说明
IncomeID | Int | 帐目编号。
AccountDate | DateTime | 建帐日期。
DateAndTime | DateTime | 输入系统时间。
Income | Int | 类型。（0支，1收）
IncomeClassID | Int | 帐目分类编号。
IncomeClassName | VarChar | 帐目分类名称。
Price | Currency | 金额。
AccountID | Int | 帐户编号。
AccountName | VarChar | 帐户名称。
Remark | VarChar | 备注。
SchoolID | Int | 校区编号。
SchoolName | VarChar | 校区名称。
TrueName | VarChar | 录入人姓名。
UserID | Int | 录入人工号。


IncomeClass 帐目分类表

存储帐目分类信息。

字段 | 类型 | 说明
IncomeClassID | Int | 帐目分类编号。
IncomeClassName | VarChar | 帐目分类名称。
Income | Int | 类型。（0支，1收）
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Leave 请假表

请假表，存储学员请假信息。

字段 | 类型 | 说明
LeaveID | Int | 请假编号。
StudentID | Int | 请假的学员编号。
StudentName | VarChar | 请假的学员姓名。
DateAndTime | DateTime | 办理请假的时间。
StartDate | DateTime | 请假的开始时间。（精确到时间部分）
EndDate | DateTime | 请假的结束时间。（精确到时间部分）
Remark | VarChar | 备注。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。


LessonTime 排课表

班级的上课课次表，一课次可以上多课时。

字段 | 类型 | 说明
LessonTimeID | Int | 排课课次编号。
ClassID | Int | 班级编号。
Subject | VarChar | 主题。
StartDate | DateTime | 上课时间。（精确到时间部分）
EndDate | DateTime | 下课时间。（精确到时间部分）
Lessons | Decimal | 课时。
FactCount | Int | 出勤人数。
LateCount | Int | 迟到人数。
AdvanceCount | Int | 早退人数。
TruancyCount | Int | 旷课人数。
LeaveCount | Int | 请假人数。
LessonType | Int | 上课类型。（0补课，1正常）
TeacherID | Int | 老师工号。
LeStateID | Int | 上课状态。（0未上课，1已上课）
ClassroomID | Int | 教室编号。
Remark | VarChar | 备注。
DateAndTime | DateTime | 排课操作日期。
UserID | Int | 排课者工号。
CreateType | Int | 排课方式。（0常规，1考勤触发排课【一对一模式】，2约课）
AssistantID | Int | 助教工号。
AssistantName | VarChar | 助教姓名。
Place | Int | 补课地方。（0 本班，1他班）
ToLessonTimeID | Int | 在他班补课的排课号。
StudentID | Int | 学员自助排课时的学号。
LessonFee | Currency | 主讲课时费。
TALessonFee | Currency | 助教课时费。
VideoUrl | VarChar | 上传视频地址。
ARemind | Int | 上课提醒标识，已过时。
ExeAbsent | Int | 是否计算过旷课信息。


Media 媒体表

媒体表。广告来源设置信息。

字段 | 类型 | 说明
MediaID | Int | 媒体编号。
MediaName | VarChar | 媒体名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Online 员工在线表

记录员工在线信息。

字段 | 类型 | 说明
UserID | Int | 员工工号。
SessionID | VarChar | 会话变量。
TrueName | VarChar | 姓名。
UserFace | VarChar | 头像。
Location | VarChar | 位置。
IP | VarChar | IP地址。
DateAndTime | DateTime | 来访时间。
LastDateTime | DateTime | 最后活动时间。


OtherFee 收费项表

收费项表，除商品和课程之外的收费统称为收费项收费，比如：学员的空调费、接送费等。

字段 | 类型 | 说明
OtherFeeID | Int | 收费项编号。
OtherFeeName | VarChar | 收费项名称。
Price | Currency | 金额。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。
QType | Int | 量化方式。（1按数量，2按时间）
UnitName | VarChar | 单位名称。


OtherFeeUnit 其它收费单位表

其它收费单位表。

字段 | 类型 | 说明
OtherFeeUnitID | Int | 其它收费单位编号。
OtherFeeUnitName | VarChar | 其它收费单位名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Payment 学员账户表

学员账户表，存储学员账户信息。

字段 | 类型 | 说明
PaymentID | Int | 帐单编号。
StudentID | Int | 所属学员编号。
StudentName | VarChar | 所属学员姓名。
PaymentTypeID | Int | 帐单类型。（1交费，2退费，3借款，4扣除借款，5业务扣费，6业务退费，7赠送，8赠送收回）
PaymentTypeName | VarChar | 帐单类型名称。
PayMethodID | Int | 支付方式编号。
PayMethodName | VarChar | 支付方式名称。
PayMoney | Currency | 金额。
DateAndTime | DateTime | 办理时间。
Remark | VarChar | 备注。
CreditExpiration | DateTime | 信用到期时间。（只有当帐单类型为借款时有效）
PrintCount | Int | 打印次数。
PostSchoolID | Int | 办理网点编号。
PostSchoolName | VarChar | 办理网点名称。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
LockState | Int | 状态。（系统字段）
InsertTime | DateTime | 数据写入时间。（系统字段）
RelaPaymentID | Int | 关联的充值单号。
BillID | VarChar | 关联的消费单号。


PaymentLog 支付宝日志表

支付宝支付日志。

字段 | 类型 | 说明
PaymentLogID | VarChar | 支付日志编号。
Pay | Currency | 金额。
DateAndTime | DateTime | 时间。
PayState | Int | 支付状态。（0未付，1成功）
PaymentID | Int | 学员帐户帐单号。
StudentID | Int | 学员编号。
StudentName | VarChar | 学员姓名。
AlipayAccount | VarChar | 支付宝帐号。
PayType | Int | 支付类型。（0支付宝，1微信）
Trade_No | VarChar | 交易号。
BillID | VarChar | 消费单号。


PayMethod 支付方式表

设置学员交费支付方式。

字段 | 类型 | 说明
PayMethodID | Int | 支付方式编号。
PayMethodName | VarChar | 支付方式名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


PeriodTime 时间段表

上课时间段表，用于班级排课时设置排课参数。

字段 | 类型 | 说明
PeriodTimeID | Int | 上课时间段编号。
StartTime | VarChar | 开始时间。
EndTime | VarChar | 结束时间。
GroupType | Int | 分组编号。
Orders | Int | 排序。


PeriodTimeGroup 时段分组表

时间段分组表。

字段 | 类型 | 说明
PeriodTimeGroupID | Int | 时间段组编号。
PeriodTimeGroupName | VarChar | 时间段组名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


PointsExchange 积分兑换表

积分兑换表。

字段 | 类型 | 说明
PointsExchangeID | Int | 兑换编号。
StudentID | Int | 学员编号。
StudentName | VarChar | 学员姓名。
Points | Int | 消耗积分数。
Amount | Int | 兑换的物品数量。
StoCommodityID | Int | 所属仓库关联表编号（注：这里不是仓库编号，而是关联表编号,StoCommodity关联表里记录了每种商品在不同仓库里的库存信息）。
DateAndTime | DateTime | 兑换日期。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
InsertTime | DateTime | 数据写入时间。（系统字段）


PotCourse 咨询课程表

咨询模块里的课程信息表。

字段 | 类型 | 说明
CourseID | Int | 课程编号。
CourseName | VarChar | 课程名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Potential 咨询信息表

咨询信息表。

字段 | 类型 | 说明
PotentialID | Int | 咨询编号。
PotentialName | VarChar | 潜在学员姓名。
CourseID | Int | 咨询课程编号。
CourseName | VarChar | 咨询课程名称。
SourceType | Int | 来源类型。（0内部，1外部）
DateAndTime | DateTime | 咨询日期。
Sex | Int | 性别。
Appellation | VarChar | 称呼。
OldStudent | Int | 是否老学员。（0否，1是）
StudentID | Int | 学员编号。（只有在是老学员的情况下才可以显示）
Tel | VarChar | 电话。
MobileTel | VarChar | 手机。
Tel1 | VarChar | 其它电话1。
Tel2 | VarChar | 其它电话2。
Tel3 | VarChar | 其它电话3。
QQ | VarChar | QQ。
Email | VarChar | 邮箱。
TimeRule | VarChar | 上课规律。
MediaID | Int | 媒体编号。
MediaName | VarChar | 媒体名称。
LastPostName | VarChar | 最后回访人的姓名。
LastPostTime | DateTime | 最后回访时间。
ReCount | Int | 回访次数。
StatusID | Int | 客户状态编号。（1潜在，2战败，3成功）
StatusName | VarChar | 客户状态名称。
NextReplyDate | DateTime | 下次回访日期。（不支持时间部分）
Remark | VarChar | 备注。
UserID | Int | 录入人工号。
TrueName | VarChar | 录入人姓名。
SchoolID | Int | 校区编号。
SchoolName | VarChar | 校区名称。
InsertTime | DateTime | 数据写入时间。（系统字段）
Custom1 | VarChar | 自定义字段，最大长度255字节。
Custom2 | VarChar | 自定义字段，最大长度255字节。
Custom3 | VarChar | 自定义字段，最大长度255字节。
Custom4 | VarChar | 自定义字段，最大长度255字节。
Custom5 | VarChar | 自定义字段，最大长度255字节。
Gatherers | VarChar | 数据采集人。
LastPostID | Int | 最后回访编号。
LastPostContent | VarChar | 最后回访的内容。
StatusReasonID | Int | 状态描述编号。
StatusReasonName | VarChar | 状态描述名称。
Birthday | DateTime | 生日。
HomeAddress | VarChar | 家庭地址。
PostCode | VarChar | 邮编。
School | VarChar | 学校。
Grade | VarChar | 年级。
Class | VarChar | 班级。
IsPublic | Int | 是否为共享数据。（0否，1是）
PrivateDate | DateTime | 私有化的时间。
FreeTimes | VarChar | 空间时段。
Country | VarChar | 国家。
Nation | VarChar | 民族。
Province | VarChar | 省份。
City | VarChar | 城市。
Area | VarChar | 县区。
Street | VarChar | 街道。
Consignee | VarChar | 收件人。
ConsigneePhone | VarChar | 收件人手机。
ReplyID | Int | 最后回访编号。
WeiXin | VarChar | 微信号。
ImportBatchID | Int | 批量导入的批次号。
GatherID | Int | 采集人工号。
GatherName | VarChar | 采集人姓名。


Printing 打印表

记录打印报表供客户端下载后打印。

字段 | 类型 | 说明
PrintID | Int | 打印编号。
Title | VarChar | 标题。
Content | VarChar | 内容。
DateAndTime | DateTime | 时间。
UserID | Int | 打印者工号。
TrueName | VarChar | 打印者姓名。
SchoolID | Int | 校区编号。
DocTypeID | Int | 文档类型。
BaseAddress | VarChar | 基础URL地址。
Args | VarChar | 其它参数。


Provider 供应商表

供应商信息表。

字段 | 类型 | 说明
ProviderID | Int | 供应商编号。
ProviderName | VarChar | 供应商姓名。
LinkMan | VarChar | 联系人。
Tel | VarChar | 电话。
Address | VarChar | 地址。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Reminder 提醒表

系统提醒表。

字段 | 类型 | 说明
ReminderID | Int | 提醒编号。
Title | VarChar | 标题。
Message | VarChar | 内容。
CountSql | VarChar | 数量语法。
ContentSql | VarChar | 展开查询语法。
NavigateUrl | VarChar | 重定向。
Target | VarChar | 打开方式。
Remark | VarChar | 备注。
Allow | Int | 此字段是控制用户和用户组的访问权限，针对GroupAndUsers字段。（1允许，0禁止）
GroupAndUsers | VarChar | 用户或用户组。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


Reply 咨询回访表

回访表。

字段 | 类型 | 说明
ReplyID | Int | 回访编号。
PotentialID | Int | 咨询信息编号。
DateAndTime | DateTime | 回访日期。
Content | VarChar | 内容。
StatusID | Int | 客户状态编号。（1潜在，2战败，3成功）
StatusName | VarChar | 客户状态名称。
UserID | Int | 回访人工号。
TrueName | VarChar | 回访人姓名。
InsertTime | DateTime | 数据写入时间。
StatusReasonID | Int | 状态描述编号。
StatusReasonName | VarChar | 状态描述名称。


Report 报表

存储系统报表及用户自定义报表。

字段 | 类型 | 说明
ReportID | Int | 报表编号。
ReportName | VarChar | 报表名称。
DataSetID | Int | 数据集编号。
DataSetName | VarChar | 数据集名称。
Content | VarChar | 报表内容。
Location | VarChar | 出现位置。
LockState | Int | 状态。（0禁用，1可用）
Remark | VarChar | 备注。
Allow | Int | 此字段是控制用户和用户组的访问权限，针对GroupAndUsers字段。（1允许，0禁用)
GroupAndUsers | VarChar | 用户或用户组。
Orders | Int | 排序。


Reward 奖罚类型表

奖罚类型表。

字段 | 类型 | 说明
RewardID | Int | 奖罚类型编号。
RewardName | VarChar | 奖罚类型名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


School 校区表

存储校区信息。

字段 | 类型 | 说明
SchoolID | Int | 校区编号。
SchoolName | VarChar | 校区名称。
Tel | VarChar | 电话。
Address | VarChar | 地址。
HardwarePwd | VarChar | 客户端连接的密码。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。
OpenDisplay | Int | 是否对外显示，微网站学员客户端等。（0否，1是）
Courses | VarChar | 本校课程。


Score 成绩表

记录学员阶段成绩。

字段 | 类型 | 说明
ScoreID | Int | 成绩编号。
ScoreName | VarChar | 成绩名称。
DateAndTime | DateTime | 时间。
Score | Decimal | 成绩。
Remark | VarChar | 备注。
StuClassID | Int | 选班号。
Orders | Int | 排序。


Scrapped 损溢表

进销存损溢数据表。

字段 | 类型 | 说明
ScrappedID | Int | 损溢编号。
ScrappedTypeID | Int | 损溢类型。（0报废，1溢出）
DateAndTime | DateTime | 办理时间。
Amount | Int | 数量。
UnitName | VarChar | 单位。
Remark | VarChar | 备注。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
CommodityID | Int | 商品编号。
CommodityName | VarChar | 商品名称。
StoCommodityID | Int | 所属仓库关联表编号（注：这里不是仓库编号，而是关联表编号,StoCommodity关联表里记录了每种商品在不同仓库里的库存信息）。


Search 查询表

存储系统内置SQL查询信息，及自定义SQL查询。

字段 | 类型 | 说明
SearchID | Int | 查询编号。
SearchName | VarChar | 查询名称。
DateAndTime | DateTime | 创建日期。
Content | VarChar | SQL主查询内容。
ShowContent | VarChar | SQL子查询内容。
SetGroup | VarChar | 设置此查询出现的模块。
LockState | Int | 状态。（0禁用，1可用）
Remark | VarChar | 备注。
Allow | Int | 此字段是控制用户和用户组的访问权限，针对GroupAndUsers字段。（1允许，0禁用)
GroupAndUsers | VarChar | 用户或用户组。
Orders | Int | 排序。
SearchType | Int | 查询类型。（0查询，1插件）
Params | VarChar | 查询参数。
Version | Decimal | 查询版本。
AppID | Int | 应用市场中的应用编号。
Source | Int | 来源。
Author | VarChar | 作者。


SendEvent 短信事件表

短信事件表。

字段 | 类型 | 说明
SendEventID | Int | 短信事件编号。
SendEventName | VarChar | 短信事件名称。
Content | VarChar | 短信内容。
LockState | Int | 状态。（0禁用，1可用）
DelayMinute | Int | 延时分钟数。


Sending 短信队列表

短信发送队列，所以待发短信都将首先进入这张表。

字段 | 类型 | 说明
smsID | Int | 短信编号。
ClientID | Int | 接收方编号。
ClientName | VarChar | 接收方名称。
TargetNo | VarChar | 接收方手机号。
Content | VarChar | 短信内容。
DateAndTime | DateTime | 发送时间。
Errors | Int | 错误次数。
ErrorNum | Int | 错误代码。
DataLevel | Int | 系统保留字段。
UserLevel | Int | 用户短信分级，1通知，2广告。
BatchAmount | Int | 记录同批发送量。
UserID | Int | 发送者工号。
TrueName | VarChar | 发送者姓名。
SchoolID | Int | 校区编号。
ClassID | Int | 班级编号。


SendLog 短信日志表

记录短信的发送结果。

字段 | 类型 | 说明
smsID | Int | 短信编号。
ClientID | Int | 接收方编号。
ClientName | VarChar | 接收方名称。
TargetNo | VarChar | 接收方手机号。
Content | VarChar | 短信内容。
DateAndTime | DateTime | 发送时间。
Result | Int | 发送结果状态。（0失败，1成功）
ErrorNum | Int | 错误代码。
DataLevel | Int | 系统保留字段。
UserLevel | Int | 用户短信分级，1通知，2广告。
BatchAmount | Int | 记录同批发送量。
UserID | Int | 发送者工号。
TrueName | VarChar | 发送者姓名。
SchoolID | Int | 校区编号。
ClassID | Int | 班级编号。
ValidCount | Int | 有效号码数。
BillingCount | Int | 扣费数量。
Gangway | Int | 发送通道。


SignLog 考勤日志表

记录所有ID/指纹考勤动作。

字段 | 类型 | 说明
SignLogID | Int | 考勤日志编号。
KeyID | Int | 关键字。（学号或工号）
IsEmp | Int | 是否是员工考勤（1是，0不是）
State | Int | 考勤状态。（-1卡号不存在，0今天没课，1签到成功，2重复签到，3课时已上完，4签退成功，5刷卡无效）
AttendID | Int | 系统考勤记录编号。
DateAndTime | DateTime | 时间。
SignInID | VarChar | ID卡号。


SmsReceive 收短信表

用于记录接收到的短信。

字段 | 类型 | 说明
SMSID | Int | 编号。
Mobile | VarChar | 手机号。
Msg | VarChar | 内容。
RepTime | DateTime | 回复时间。
ClientID | Int | 客户号。
ClientName | VarChar | 客户姓名。
UserID | Int | 员工号。


SmsTemplate 短信模板表

用于存储自定义的短信模板，方便重复使用。

字段 | 类型 | 说明
SmsTemplateID | Int | 短信模板编号。
SmsTemplateName | VarChar | 短信模板名称。
UserLevel | Int | 用户短信分级，1通知，2广告。
Content | VarChar | 内容。
Orders | Int | 排序。


Status 潜在学员状态表

用于自定义潜在学员的分类。系统内置了三种状态，潜在、成功、战败。

字段 | 类型 | 说明
StatusID | Int | 状态编号。
StatusName | VarChar | 状态名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


StatusReason 状态描述表

对潜在学员状态的进一步描述。如描述成交的心得，描述不成交的原因等。

字段 | 类型 | 说明
StatusReasonID | Int | 状态描述编号。
StatusReasonName | VarChar | 状态描述名称。
StatusID | Int | 状态编号。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


StoCommodity 仓库商品关联表

仓库商品关联表，记录了每种商品在不同仓库里的库存信息。

字段 | 类型 | 说明
StoCommodityID | Int | 编号。
CommodityID | Int | 商品编号。
CommodityName | VarChar | 商品名称。
StoreroomID | Int | 仓库编号。
StoreroomName | VarChar | 仓库名称。
Amount | Int | 库存数量。


Storeroom 仓库表

用来存储仓库信息。

字段 | 类型 | 说明
StoreroomID | Int | 仓库编号。
StoreroomName | VarChar | 仓库名称。
Tel | VarChar | 电话。
Address | VarChar | 地址。
SchoolID | Int | 校区编号。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。
Sell | Int | 是否可用于销售。（0不可以，1可以）


StuClass 选班表

选班表记录学号与班级的关系，记录学员在本班的可上课时数，上课进度，成绩等。

字段 | 类型 | 说明
StuClassID | Int | 选班号。
BillItemID | Int | 消费明细编号。
StudentID | Int | 学员编号。
StudentName | VarChar | 学员姓名。
ClassID | Int | 班级编号。
ClassName | VarChar | 班级名称。
DateAndTime | DateTime | 选班日期。
Lessons | Decimal | 已购总课时。
CourseProgress | Decimal | 课程进度。
ScStateID | Int | 选班状态。（1正常，2插班，3转班，4休学，5退学，6弃学）
ContinueReg | Int | 选班类型。（0试听，1新增，2续报）
Score | Decimal | 成绩。
Score1 | Decimal | 备用成绩1。
Score2 | Decimal | 备用成绩2。
Score3 | Decimal | 备用成绩3。
Score4 | Decimal | 备用成绩4。
Score5 | Decimal | 备用成绩5。
OpinionDate | DateTime | 评价日期。
Opinion | VarChar | 评价内容。
Grade | VarChar | 成绩等级。
FactCount | Int | 出勤次数。
LateCount | Int | 迟到次数。
AdvanceCount | Int | 早退次数。
TruancyCount | Int | 旷课次数。
LeaveCount | Int | 请假次数。
FillCount | Int | 补课次数。
CertName | VarChar | 证书类型。
CertNumber | VarChar | 证书编号。
Remark | VarChar | 备注。
LessonPriceArray | VarChar | 描述学员在本班的学费、单价、数量等细节。
SchoolID | Int | 上课校区编号。
SchoolName | VarChar | 上课校区名称。
PostSchoolID | Int | 选班网点编号。
PostSchoolName | VarChar | 选班网点名称。
ChangeDate | DateTime | 异动日期。（精确到时间部分）
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
InsertTime | DateTime | 数据写入时间。
LastBillItemID | Int | 最后的明细单号。
ExpiryDate | DateTime | 到期时间。（精确到时间部分）
LastSelectDate | DateTime | 最后选班日期。（精确到时间部分）
QType | Int | 量化方式。（1按课时，2按时间）
SyncClassTime | Int | 与班级结束日期同步。
LastToDate | DateTime | 最近一次续费时间。（精确到时间部分）
SourceClassID | Int | 来自原班级编号。


Student 学员表

学员基础信息表。

字段 | 类型 | 说明
StudentID | Int | 学员编号。
StudentName | VarChar | 学员姓名。
PYSimple | VarChar | 拼音简码。
Byname | VarChar | 别名。
Appellation | VarChar | 称呼。
Sex | Int | 性别。（0女，1男）
StudentType | Int | 学员类型。（0学生，1上班族）
Birthday | DateTime | 出生日期。
SchoolID | Int | 校区编号。
SchoolName | VarChar | 校区名称。
Photo | VarBinary | 相片。
ExistPhoto | Boolean | 是否存在相片。
Password | VarChar | 密码。
DateAndTime | DateTime | 报名日期。
Tel | VarChar | 电话。
MobileTel | VarChar | 手机。
Tel1 | VarChar | 其它电话1。
Tel2 | VarChar | 其它电话2。
Tel3 | VarChar | 其它电话3。
Email | VarChar | 电子信箱。
HomeAddress | VarChar | 家庭地址。
PostCode | VarChar | 邮编。
School | VarChar | 学校。
Grade | VarChar | 年级。
Class | VarChar | 班级。
Company | VarChar | 单位。
Headship | VarChar | 职务。
IDcard | VarChar | 身份证号。
SignInID | VarChar | ID卡号。
LastClassName | VarChar | 最后加入的班级。
StuClassCount | Int | 选班数量。
ConsultantID | Int | 所属咨询员编号。
ConsultantName | VarChar | 所属咨询员姓名。
MediaID | Int | 媒体编号。
MediaName | VarChar | 媒体名称。
Remark | VarChar | 备注。
UserID | Int | 录入者编号。
TrueName | VarChar | 录入者姓名。
BillCount | Int | 消费单数量。
ConsumedMoney | Currency | 消费金额。
CreditMoney | Currency | 欠费金额。
AvailableMoney | Currency | 可用金额。
GiveMoney | Currency | 赠送金额。
CreditExpiration | DateTime | 欠费到期时间。
CreditRemark | VarChar | 欠费原因。
Points | Int | 积分。
QQ | VarChar | QQ号。
Diploma | VarChar | 学历。
VIPLastDate | DateTime | VIP到期日期。（精确到时间部分）
SignInSMS | Int | ID签到时是否发送短信。（0不发送，1发送）
FatherName | VarChar | 父亲姓名。
FatherMobileTel | VarChar | 父亲电话。
FatherUnit | VarChar | 父亲工作单位。
FatherHeadship | VarChar | 父亲职务。
MotherName | VarChar | 母亲姓名。
MotherMobileTel | VarChar | 母亲电话。
MotherUnit | VarChar | 母亲工作单位。
MotherHeadship | VarChar | 母亲职务。
FingerState | Int | 指纹状态。（0禁用，1可用）
FingerCode | VarChar | 指纹编码。
LastPostName | VarChar | 最后回访人的姓名。
LastPostTime | DateTime | 最后回访时间。
ReCount | Int | 回访次数。
NextReplyDate | DateTime | 下次回访日期。（不支持时间部分）
InsertTime | DateTime | 数据写入时间。
Custom1 | VarChar | 自定义字段，长度255字节。
Custom2 | VarChar | 自定义字段，长度255字节。
Custom3 | VarChar | 自定义字段，长度255字节。
Custom4 | VarChar | 自定义字段，长度255字节。
Custom5 | VarChar | 自定义字段，长度255字节。
LastPostID | Int | 最后关怀人工号。
LastPostContent | VarChar | 最后关怀内容。
Country | VarChar | 国家。
Nation | VarChar | 民族。
Province | VarChar | 省份。
City | VarChar | 城市。
Area | VarChar | 区县。
Street | VarChar | 街道。
Consignee | VarChar | 收件人。
ConsigneePhone | VarChar | 收件人电话。
WeiXin | VarChar | 微信号。
Height | Int | 身高。
Weight | Int | 体重。
LockState | Int | 状态。（0毕业，1在读）
ImportBatchID | Int | 导入批次号。
RegType | Int | 注册方式。（0微信，1普通）
LastLoginIP | VarChar | 最后登录的IP。
LastLoginTime | DateTime | 最后登录的时间。
Logins | Int | 登录次数。
wxState | Int | 绑定微信的状态。（0未绑定，1已绑定）


StuPoints 积分表

记录学员积分。

字段 | 类型 | 说明
StuPointsID | Int | 积分编号。
StudentID | Int | 学号。
Points | Int | 积分。
DateAndTime | DateTime | 日期。
Remark | VarChar | 增减积分原因。
UserID | Int | 录入人工号。
TrueName | VarChar | 录入人姓名。
InsertTime | DateTime | 录入数据库时间。


StuReply 学员回访表

回访正式学员信息。

字段 | 类型 | 说明
ReplyID | Int | 回访编号。
StudentID | Int | 学员编号。
DateAndTime | DateTime | 回访日期。
Content | VarChar | 内容。
UserID | Int | 回访人工号。
TrueName | VarChar | 回访人姓名。
NextReplyDate | DateTime | 下次回访时间。（不支持时间部分）
InsertTime | DateTime | 数据写入时间。


StuRole 学员角色表

设置不同的学员角色显示不同的字段。

字段 | 类型 | 说明
StuRoleID | Int | 学员角色编号。
StuRoleName | VarChar | 学员角色名称。
FieldStates | VarChar | 字段状态集合。
DefaultRole | Int | 默认角色。（0否，1是）
Orders | Int | 排序。


StuService 服务表

用于学员除课程、进销存商品之外的服务，对应系统里的其它收费。

字段 | 类型 | 说明
StuServiceID | Int | 学员服务编号。
OtherFeeID | Int | 其它收费编号。
BillItemID | Int | 明细单编号。
StudentID | Int | 学员学号。
StudentName | VarChar | 学员姓名。
QType | Int | 量化方式。（1按课时，2按时间）
StartDate | DateTime | 开始日期。（精确到时间部分）
EndDate | DateTime | 结束日期。（精确到时间部分）
Amount | Decimal | 数量。
BackAmount | Decimal | 返回数量。
ProgressAmount | Decimal | 消耗数量。
DateAndTime | DateTime | 时间。
Remark | VarChar | 备注。
PostSchoolID | Int | 办理校区编号。
PostSchoolName | VarChar | 办理校区名称。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
InsertTime | DateTime | 数据写入时间。
LastBillItemID | Int | 最后的明细单号。
NextPrice | Decimal | 下次续费金额。
SubCount | Int | 消耗记录数。


StuServiceSub 服务消耗表

学员其它收费服务消耗表。

字段 | 类型 | 说明
StuServiceSubID | Int | 学员其它收费消耗编号。
StuServiceID | Int | 学员其它收费编号。
Type | Int | 消耗类型。（0 退回 1消耗）
Amount | Decimal | 消耗数量。
BackPrice | Currency | 退回金额。
DateAndTime | DateTime | 时间。
Remark | VarChar | 备注。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
PostSchoolID | Int | 办理校区编号。
PostSchoolName | VarChar | 办理校区名称。
PaymentID | Int | 退费支付编号。
InsertTime | DateTime | 数据写入时间。


SubStuAccount 学员关联子帐号表

可以实现一键登录到其他学员。比如两里有多个孩子在同一机构学习时使用。

字段 | 类型 | 说明
StudentID | Int | 学号
SubStudentID | Int | 关联学号
SubStudentName | VarChar | 关联学员姓名
SubSex | Int | 关联学员性别
SubFace | VarChar | 关联学员头像


SysLog 系统日志表

记录系统操作日志。

字段 | 类型 | 说明
SysLogID | Int | 日志编号。
SysLogType | Int | 日志类型。（1登录，2更新，3删除，4备份）
SourceURL | VarChar | 来源URL。
DateAndTime | DateTime | 时间。
UserID | Int | 操作者编号。
UserName | VarChar | 操作者登录名。
TrueName | VarChar | 操作者姓名。
IP | VarChar | IP地址。
SchoolName | VarChar | 校区名称。


Task 任务表

存储任务信息。

字段 | 类型 | 说明
TaskID | Int | 任务编号。
TaskName | VarChar | 任务名称。
ToUserID | Int | 办理人工号。
ToTrueName | VarChar | 办理人姓名。
TaskContent | VarChar | 任务内容。
DateAndTime | DateTime | 创建任务日期。
StartDate | DateTime | 任务执行开始时间。
EndDate | DateTime | 任务执行结束时间。
StatusID | Int | 状态编号。（0未处理，1办理中，2已完成）
StatusName | VarChar | 状态名称。
TrueName | VarChar | 发布人工号。
UserID | Int | 发布人姓名。
ReCount | Int | 完成进度数。
LastPostTime | DateTime | 最后执行任务的进度日期。


TaskReply 任务进度表

存储任务完成进度信息。

字段 | 类型 | 说明
ReplyID | Int | 任务进度编号。
TaskID | Int | 任务编号。
DateAndTime | DateTime | 进度日期。
Content | VarChar | 完成进度内容。
StatusID | Int | 进度状态。（1办理中，2已完成）
StatusName | VarChar | 进度名称。
UserID | Int | 办理人工号。
TrueName | VarChar | 办理人姓名。


Timecard 员工考勤表

记录员工通过ID或指纹仪采集的考勤信息。

字段 | 类型 | 说明
TimecardID | Int | 员工出勤编号。
DateAndTime | DateTime | 出勤日期。
AMStart | DateTime | 上午上班时间。
AMEnd | DateTime | 上午下班时间。
PMStart | DateTime | 下午上班时间。
PMEnd | DateTime | 下午下班时间。
NightStart | DateTime | 晚上上班时间。
NightEnd | DateTime | 晚上下班时间。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。
SchoolID | Int | 校区编号。


TuneOut 调拨表

记录仓库间商品的相互调拨。

字段 | 类型 | 说明
TuneOutID | Int | 调拨编号。
StoCommodityID | Int | 被抽调的商品及仓库编号。
ToStoCommodityID | Int | 目标商品及仓库编号。
DateAndTime | DateTime | 调拨时间。
Amount | Int | 数量。
Remark | VarChar | 备注。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。


Unit 商品单位表

商品单位表。

字段 | 类型 | 说明
UnitID | Int | 商品单位编号。
UnitName | VarChar | 商品单位名称。
LockState | Int | 状态。（0禁用，1可用）
Orders | Int | 排序。


UseCommodity 仓库领用表

登记从仓库领用物资的信息。

字段 | 类型 | 说明
UseCommodityID | Int | 领用编号。
UseCommodityTypeID | Int | 领用类型。（0退领，1领用）
StoCommodityID | Int | 被领用的商品及仓库关联编号。
DateAndTime | DateTime | 领用日期。
CommodityID | Int | 商品编号。
CommodityName | VarChar | 商品名称。
Amount | Int | 数量。
UnitName | VarChar | 单位。
Remark | VarChar | 备注。
ReturnDate | DateTime | 归还日期。（不支持时间部分）
ReturnState | Int | 是否归还。（0不用，1用）
ToUserID | Int | 领用人工号。
ToTrueName | VarChar | 领用人姓名。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。


UserGroup 角色表

用户组，用户角色及权限。

字段 | 类型 | 说明
UserGroupID | Int | 用户组编号。
UserGroupName | VarChar | 用户组名称。
Purview | VarChar | 用户组权限。
PurviewGroup | VarChar | 用户组权限。（通过Purview计算出模块权限）
PurviewRole | VarChar | 用户组权限。（通过Purview计算出系统内置角色权限）
Remark | VarChar | 备注。
UserCount | Int | 用户数。
SysRole | Int | 系统内置角色。（1管理员，2顾问，3老师）
Orders | Int | 排序。


UserReward 员工奖罚表

用来记录员工的奖罚信息。

字段 | 类型 | 说明
UserRewardID | Int | 奖罚编号。
ToUserID | Int | 被奖罚员工编号。
DateAndTime | DateTime | 日期。
Pay | Currency | 金额。
RewardID | Int | 奖罚类型编号。
RewardName | VarChar | 奖罚类型名称。
Remark | VarChar | 备注。
UserID | Int | 经办人工号。
TrueName | VarChar | 经办人姓名。


Users 用户表

系统用户表，员工表。

字段 | 类型 | 说明
UserID | Int | 工号。
UserName | VarChar | 登录名。
TrueName | VarChar | 姓名。
Password | VarChar | 密码。
Sex | Int | 性别。（0女，1男）
UserFace | VarChar | 用户头像。
Birthday | DateTime | 出生日期。
Online | Int | 是否在线。（0离线，1在线）
Photo | VarBinary | 用户相片。
Pluralist | Int | 是否兼职。（0否，1是）
IsTeacher | Int | 是否授课。（0不授，1授课）
ComeDate | DateTime | 任聘日期。
ContractDate | DateTime | 合同到期时间。
OutDate | DateTime | 离职日期。
Course | VarChar | 所授课程。
FinishSchool | VarChar | 毕业学校。
Diploma | VarChar | 学历。
Resume | VarChar | 简历。
Tel | VarChar | 电话。
MobileTel | VarChar | 手机。
UserEmail | VarChar | 电子邮箱。
HomeAddress | VarChar | 家庭地址。
PostCode | VarChar | 邮编。
Headship | VarChar | 职务。
IDcard | VarChar | 身份证号。
SignInID | VarChar | ID卡号。
Logins | Int | 登录系统次数。
LastLoginTime | DateTime | 最后登录时间。
LastLoginIP | VarChar | 最后登录IP。
BasePay | Currency | 基本工资。
HourFee | Currency | 课时费。（1小时课时薪资）
SchoolID | Int | 校区编号。
SchoolName | VarChar | 校区名称。
LockState | Int | 状态。（0禁用，1可用）
Parents | Int | 隶属角色（用户组）数量。
FingerState | Int | 指纹考勤状态。（0禁用，1可用）
FingerCode | VarChar | 指纹编码。
Custom1 | VarChar | 自定义字段，255字节。
Custom2 | VarChar | 自定义字段，255字节。
Custom3 | VarChar | 自定义字段，255字节。
Custom4 | VarChar | 自定义字段，255字节。
Custom5 | VarChar | 自定义字段，255字节。
wxState | Int | 绑定微信的状态。（0未绑定，1已绑定）